l
logo astronomo.org  astrónomo.org   Red Social de aficionados a la Astronomía y Observación astronómica Bienvenido(a), Visitante
 Quiero Participar o ingresa
Ingresar nombre de usuario, contraseña, duración de la sesión
  

Búsqueda Avanzada     

recomendados por nuestro foro Recomendando desde 2009 a:
Telescopio en Astroshop
... página cargada a fecha y hora :
275617 post, 19575 Temas, 13320 users
último usuario registrado:  sergitostado
avatar invitado
INICIO LOGIN CALENDARIO LISTA TAG'S*_ GALERÍA IMÁGENES
ASTROFOTOGRAFÍA
LINKS APP'S ¿QUÉ TELESCOPIO COMPRAR?
GUÍA PARA ELEGIR BIEN
?canal RSS astronomo.org
RSS

Dithering - Pregunta sobre que valores usáis ? y pausa?

Página: [1]    bajar  * y última página *
Imprimir
clase Autor Tema: Dithering - Pregunta sobre que valores usáis ? y pausa?  (Leído 1473 veces)
0
astrons:   votos: 0
teredur

**
Vitoria-Gasteiz 
desde: ago, 2017
mensajes: 236
clik ver los últimos




minimensaje
« del : Vie, 28 Ago 2020, 08:30 UTC »

En las últimas salidas me he dado cuenta de un problema en las imágenes en el que no había caído hasta ahora:

Uso Ekos (astroberry) para automatizar las tomas, tengo configurado el dithering para que lo realice cada 4 tomas, con una derivación de 2 píxel, dado que la relación guia/telescopio que tengo es de 4,62, debe mover unos 10 píxel la imagen principal.

El problema es que la siguiente toma al dithering, sala movida, lo que significa que 1 de cada 4 tomas va a la papelera.

En ekos hay un parámetro (guideSettle) que establece una pausa entre el fin del desplazamiento del dithering y el inicio de la captura, he jugado con valores de 20 a 50 segundos y si que con mas tiempo el numero de imágenes movidas disminuye, pero me parece demasiado.

Estamos hablando que normalmente consigo valores de guiado entorno al 1, entre 0,8 y 1,4. (montura ieq45 pro).

¿No es mucha pausa entre imágenes?

¿Que valores de pausas(guideSettle) usáis?



- - -

AIP
www.aipastroimaging.com

**

avatarc

Álvaro

34  Hortaleza, Madrid 
desde: mar, 2013
mensajes: 2454
clik ver los últimos

WWW


minimensaje
« respuesta #1 del : Vie, 28 Ago 2020, 09:14 UTC »

Yo en mi vida he usado dither (miento, una vez, y fue para hacer una prueba)

Nunca he tenido la necesidad de usarlo.

Sin dither os sale mal la foto o que? hmmmm

- - -

PabloBS

**

avatarc

41  madrid/extremadura 
desde: ene, 2017
mensajes: 380
clik ver los últimos




minimensaje
« respuesta #2 del : Vie, 28 Ago 2020, 10:33 UTC »

Yo en mi vida he usado dither (miento, una vez, y fue para hacer una prueba)

Nunca he tenido la necesidad de usarlo.

Sin dither os sale mal la foto o que? hmmmm

A mi sí, si no hago dithering me sale la imagen como rayada, como si el ruido en la imagen tuviera forma de lluvia, se que tiene un nombre pero ahora no me acuerdo. Ojo, este ruido se acentúa con mala puesta en estación, pero en mi caso he hecho puestas en estación muy precisas y aunque disminuye mucho sigue apareciendo si no uso dithering.
A
@teredur, has pensado en cambiarte a otro programa tipo APT o N.I.N.A. A mi con APT y PHD2 no me da ningun problema y uso el puerto de autoguide de la montura, ni siquiera la tengo conectada al ordenador.

« Últ. modif.: Vie, 28 Ago 2020, 10:36 UTC por PabloBS »
- - -

Miguelyx

**

avatarc

57  Barcelona 
desde: ago, 2013
mensajes: 4185
clik ver los últimos




minimensaje
« respuesta #3 del : Vie, 28 Ago 2020, 10:48 UTC »

Pero porque te sale movida?


El dithering lo hace cuando la camara principal ha finalizado una toma y va a empezar otra.
Creo que no le dejas tiempo entre toma y toma para que el dithering actue y vuelva a guiar de nuevo antes de que empiece la siguiente captura.

Pero lo que no acabo de entender bien es esto:

tengo configurado el dithering para que lo realice cada 4 tomas, con una derivación de 2 pixel, dado que la relación guia:telescopio que tengo es de 4,62, debe mover unos 10 pixel la imagen principal.


A ver si lo he entendido, que dada la relacion de resoluciones, el programa se desplaza unos 10 pixels o que lo tienes configurado para que se desplace unos 10 pixels respecto de la ultima toma?
Porque si es lo ultimo, porque debes desplazarla 10 pixels dada la relacion entre la resolucion del principal con la resolucion del guiado?
Entonces si usases OAG y tuvieses la misma camara en el principal y en el guiado, o que tuviesen el mismo micron las 2, cuantos pixels deberias desplazarla? 0 pixels?

- - -

teredur

**
Vitoria-Gasteiz 
desde: ago, 2017
mensajes: 236
clik ver los últimos




minimensaje
« respuesta #4 del : Vie, 28 Ago 2020, 10:58 UTC »

Cita
@teredur, has pensado en cambiarte a otro programa tipo APT o N.I.N.A. A mi con APT y PHD2 no me da ningun problema y uso el puerto de autoguide de la montura, ni siquiera la tengo conectada al ordenador.

Estoy revisando NINA, pero por un lado tendria que montarlo en un mini PC, siempre hago las capturas en el campo/monte, aumentaria el consumo respecto a la raspberry, pero es una opción .
Cita
Pero porque te sale movida?

El dithering lo hace cuando la camara principal ha finalizado una toma y va a empezar otra.
Creo que no le dejas tiempo entre toma y toma para que el dithering actue y vuelva a guiar de nuevo antes de que empiece la siguiente captura.

Pero lo que no acabo de entender bien es esto:

Perdón no me he explicado. mi teoría es que aunque la captura comienza una vez pasado el tiempo de guideSettle, la montura todavía no esta suficientemente estabilizada. es decir que tras moverse los 10 pixeles, parar realizar el dithering, empieza el guiado, paso el tiempo de guidesettle, y se inicia la captura, pero la montura sigue corrigiendo el error de guiado que se ha generado.

Pero me parecen mucho esperar mas de 40", por cada toma tras el dithering, no se .

Con AOG, la relacion sera 1:1, pero entre mi imagen principal y la de guía hay una relación de 1:4,62, 1 pixel de la imagen de guiado son 4,62 de la principal, si configuro 2 pixel (es el valor por defecto) en el dithering, la imagen principal ha de moverse 10 pixeles (9,24).

- - -

Miguelyx

**

avatarc

57  Barcelona 
desde: ago, 2013
mensajes: 4185
clik ver los últimos




minimensaje
« respuesta #5 del : Vie, 28 Ago 2020, 11:11 UTC »

Vale, hablabas de la relación entre resoluciones, dada tu config, se desplaza unos 10 pixels.
Aclarado.

Sobre lo primero, has revisado la config del backlash?
Lo tienes configurado?
Se supone que debería comerse el backlash pero si estas perdiendo tantas tomas por culpa del dithering, yo lo revisaría.
Puedes poner alguna captura del guiado justo cuando empieza la siguiente toma?

- - -

madaleno

**

avatarc

Bustarviejo (Madrid) 
desde: jun, 2015
mensajes: 4720
clik ver los últimos




minimensaje
« respuesta #6 del : Vie, 28 Ago 2020, 11:11 UTC »

Yo lo tengo configurado cada 5 tomas, 8" de espera para estabilizarse mas 6" cuando esta estabilizada y alcanza 0,5" de arco o menos para comenzar la toma. Cuanto mas agresivo sea el dither mas tiempo necesita para estabilizarse lógicamente, prueba con 1 pixel a ver que tal va, no se necesita mucho desplazamiento para evitar ese patrón de fondo.

- - -

RegMaster

**

avatarc

40  España 
desde: nov, 2010
mensajes: 683
clik ver los últimos

WWW


minimensaje
« respuesta #7 del : Vie, 28 Ago 2020, 11:23 UTC »

Cita
@teredur, has pensado en cambiarte a otro programa tipo APT o N.I.N.A. A mi con APT y PHD2 no me da ningun problema y uso el puerto de autoguide de la montura, ni siquiera la tengo conectada al ordenador.

Estoy revisando NINA, pero por un lado tendria que montarlo en un mini PC, siempre hago las capturas en el campo/monte, aumentaria el consumo respecto a la raspberry, pero es una opción .
Cita
Pero porque te sale movida?

El dithering lo hace cuando la camara principal ha finalizado una toma y va a empezar otra.
Creo que no le dejas tiempo entre toma y toma para que el dithering actue y vuelva a guiar de nuevo antes de que empiece la siguiente captura.

Pero lo que no acabo de entender bien es esto:

Perdón no me he explicado. mi teoría es que aunque la captura comienza una vez pasado el tiempo de guideSettle, la montura todavía no esta suficientemente estabilizada. es decir que tras moverse los 10 pixeles, parar realizar el dithering, empieza el guiado, paso el tiempo de guidesettle, y se inicia la captura, pero la montura sigue corrigiendo el error de guiado que se ha generado.

Pero me parecen mucho esperar mas de 40", por cada toma tras el dithering, no se .

Con AOG, la relacion sera 1:1, pero entre mi imagen principal y la de guía hay una relación de 1:4,62, 1 pixel de la imagen de guiado son 4,62 de la principal, si configuro 2 pixel (es el valor por defecto) en el dithering, la imagen principal ha de moverse 10 pixeles (9,24).

Eso es que Ekos no está haciendo bien su trabajo.
Antes de hacer dither el PHD tiene que parar de corregir y volver a conectarse al terminar el dither.
No puedes tener la corrección del PHD activada mientras se ejecuta el dither.

Aun así... es mucho tiempo, seguro que es una suma de esto que te digo más backlash de la montura.

- - -

roberbass80

**

avatarb

Rober

44  España 
desde: ene, 2015
mensajes: 331
clik ver los últimos




minimensaje
« respuesta #8 del : Vie, 28 Ago 2020, 16:32 UTC »

No estaria de más revisar esa gráfica del PHD con el PHD2 log viewer.
Es un programa que permite coger el archivo log con la historia del guiado y revisar desde la calibración hasta el guiado completo gráficamente.
Si te hace el dithering además sale anotado porque permite excluirlo de los cálculos de la estadística.
Si nos pasas ese fichero o tu mismo lo revisas podrás ver si pasa algo en el guiado, si ocurre cuando acaba el dithering, si es en medio de la toma... o si son flexiones o cualquier cosa que nada tenga que ver con el dithering.
En todos los programas existen los parámetros indicados anteriormente que deben ser suficientes para poder configurar el dithering a nuestro equipo.

El dithering es muy útil al menos teóricamente para eliminar defectos de la imagen si se selecciona al apilado y los parámetros adecuados. Debe ser lo suficientemente 'grande' como para que esos píxeles calientes o fríos caigan a una distancia diferenciada y sean estadísticamente rechazado por el apilado.

- - -

teredur

**
Vitoria-Gasteiz 
desde: ago, 2017
mensajes: 236
clik ver los últimos




minimensaje
« respuesta #9 del : Vie, 28 Ago 2020, 17:31 UTC »

Me intriga el tema, así que he mirado tanto el log de la sesion como el log de PHP, aunque Ekos lo tengo configurado para usar el control de seguimiento interno.

En el log de sesión se observa el ciclo de funcionamiento de la captura 49 de NGC6888, los tiempos están en UTC, pero en principio todo cuadra

image post site forum

Aquí el log de guiado, se ve el pico del dithering y la vuelta a la normalidad



Captura 49, donde se ven las estrellas dobles (zoom 156%)

upload url image

La 50 sin problemas.



No lo veo claro.





- - -

Miguelyx

**

avatarc

57  Barcelona 
desde: ago, 2013
mensajes: 4185
clik ver los últimos




minimensaje
« respuesta #10 del : Vie, 28 Ago 2020, 17:58 UTC »

Puedes poner un log donde se vean 2 dithering incluidos?
Porque en ese log no se aprecia nada extraño, dither y vuelta al guiado.
Quizas esos picos en AR y DEC de correccion contraria tras el dither, pero si no lo hace tras todos los dither y solo es en ese, puede ser cualquier cosa.
Pero si tienes mas picos en medio del guiado como esos que tienes tras el dither, entonces no es culpa del dither esas imagenes con estrellas dobles.

Es que la grafica del pico del dither solo se corresponde con la imagen de estrellas dobles en pleno dither, es decir que aun no ha acabado la toma o ya ha empezado la toma cuando el dither esta en pleno pico.
Porque el pico de correccion que sale justo tras el dither no se corresponde con el desplazamiento de esas estrellas que reflejan esa imagen, si fuese por esos picos tras el dither las estrellas saldrian ahuevadas pero no dobles, porque esos picos tras el dither no justifican tanto desplazamiento en la imagen.

- - -

liloo

**

avatarc

Barcelona 
desde: sep, 2014
mensajes: 228
clik ver los últimos

WWW


minimensaje
« respuesta #11 del : Vie, 28 Ago 2020, 18:14 UTC »

En mi opinion tienes el dithering demasiado agresivo, fíjate en los picos AR, 12” de arco, y DEC, 7” de arco. Yo lo reduciría y comprobaria resultados a ver si mejora, parece como si empezara la siguiente toma con la estrella guia a medio camino, como los saltos son grandes en ese momento te sale doblada.

- - -

Rober - Cielos Boreales

**

avatarc


desde: jun, 2009
mensajes: 757
clik ver los últimos

WWW


minimensaje
« respuesta #12 del : Vie, 28 Ago 2020, 19:53 UTC »

A lo mejor tienes que dejar más tiempo para que el guiado se estabilice después del dithering. Yo dejo unos 30 segundos.

- - -

roberbass80

**

avatarb

Rober

44  España 
desde: ene, 2015
mensajes: 331
clik ver los últimos




minimensaje
« respuesta #13 del : Vie, 28 Ago 2020, 20:37 UTC »

Pues si que es raro. Ahí te dice que se espera tras el dithering que lo hace a las 2:25:42, 60 segundos y efectivamente a las 2:26:43 empieza la toma que entiendo es la 49 y si miramos bien los picos de después del dithering quedarían fuera puesto que en realidad viendo la hora arriba está bastante a más a la derecha, casi en el 2:27 y si luego miramos tienes desviaciones parecidas sobre las 2:49 y la siguiente foto sale ok...
El veredicto a bote pronto es que no tiene nada que ver con el dithering, pero si te ocurre cada 4 tomas pues no vamos a negar la realidad.... Es algo que tiene que ver con que cuando hace el dithering pero no sale reflejado o al menos yo no lo veo en la gráfica así mirando un poco.
¿Alguien ve algo más?
A ver si va a ser que precisamente el tiempo de settlement es excesivo y se hace un lío. Con que tengas 5 segundos o así debería bastar.
Ya que estamos revisando la gráfica , si que parece que el valor de correción en AR (la agresividad) está algo baja. Fíjate que no llega a corregir del todo.
No es cuestión de que cada vez que corrija se pase de largo pero tampoco que no llegue. Eso si toca con cuidado si tocas esos valores, es una recomendación. Apunta tal como lo tienes ahora por si luego te va a peor  tickedoff

Edito. La desviación de las estrellas de la siguiente siendo menor parece que es en otro 'sentido'. Cuando sale dobles, ¿es el eje AR el que está así movido?

« Últ. modif.: Vie, 28 Ago 2020, 20:39 UTC por roberbass80 »
- - -

liloo

**

avatarc

Barcelona 
desde: sep, 2014
mensajes: 228
clik ver los últimos

WWW


minimensaje
« respuesta #14 del : Vie, 28 Ago 2020, 21:51 UTC »

ahora viendo el log en grande veo que efectivamente cuando empieza la toma está guiando a +-1" por lo que no parece que venga del dithering, si la hora es correcta

las 3 ultimas cifras de las tomas son correlativas? porque es raro que tengas la 48 de las 04:24:02, la 49 de las 02:28:15 y la 50 de las 04:28:24



- - -

teredur

**
Vitoria-Gasteiz 
desde: ago, 2017
mensajes: 236
clik ver los últimos




minimensaje
« respuesta #15 del : Sáb, 29 Ago 2020, 07:32 UTC »

Gracias por la ayuda, tomo nota y probare en la próxima salida.

Puedes poner un log donde se vean 2 dithering incluidos?

Esta tarde monto la raspberry y saco las gráficas

A lo mejor tienes que dejar más tiempo para que el guiado se estabilice después del dithering. Yo dejo unos 30 segundos.

Es que estoy llegando a dejar 60 s y si soluciona algunas pero en otras siguen saliendo estrellas dobles.

ahora viendo el log en grande veo que efectivamente cuando empieza la toma está guiando a +-1" por lo que no parece que venga del dithering, si la hora es correcta

las 3 ultimas cifras de las tomas son correlativas? porque es raro que tengas la 48 de las 04:24:02, la 49 de las 02:28:15 y la 50 de las 04:28:24


Muy buena observación. Si son correlativos.

Error mio, esa noche hice 2 series, y la 48 y 50 son de la segunda serie, subo la 50 de la primera serie.



- - -

teredur

**
Vitoria-Gasteiz 
desde: ago, 2017
mensajes: 236
clik ver los últimos




minimensaje
« respuesta #16 del : Sáb, 29 Ago 2020, 20:30 UTC »

Hay va la gráfica con varios ciclos de dithering:



Yo no veo nada extraño, pero las imágenes (numero - hora) 49 - 2:28, 53 - 2:35 y  57 - 2:43, las tengo archivadas como "BADS". no

- - -

Miguelyx

**

avatarc

57  Barcelona 
desde: ago, 2013
mensajes: 4185
clik ver los últimos




minimensaje
« respuesta #17 del : Sáb, 29 Ago 2020, 21:24 UTC »

Nada, no le veo nada raro a ese dithering, lo unico que se me ocurre es que las tomas tengan un tiempo modificado al real de la captura por culpa del dithering y empiecen despues del tiempo que marcan y finalizen en pleno dithering.
Haz una prueba observando cuando te genera la imagen en el disco mirando el tiempo que tarda desde que se genera hasta descargarse, eso te dira si la imagen esta aun en exposicion y generandose cuando el dithering esta actuando.
O es eso o tambien podria ser una mala config de la memoria cache del sistema o mas lenta de lo normal en la raspberry o en la camara o un defecto de la raspberry en la memoria intermedia y de ahi, si es que es asi, que te finalizen en pleno dithering por algun tipo de ralentizacion desde que se empieza a generar la imagen hasta que finaliza.
Deberias probar con otra camara con los mismos tiempos, y si pudieses con otra raspberry, eso te sacaria de dudas si el problema esta en la camara o en la raspberry.
Porque por lo que estoy viendo, lo unico que se me ocurre es alguna ralentizacion desde que se genera la imagen hasta que finaliza.

- - -

roberbass80

**

avatarb

Rober

44  España 
desde: ene, 2015
mensajes: 331
clik ver los últimos




minimensaje
« respuesta #18 del : Dom, 30 Ago 2020, 18:12 UTC »

Yo tampoco veo nada raro en la gráfica, apunta más a un tema de programa o sistema, puede que haya un retraso entre el Ekos y el PHD2 en la coordinación; que algo que tenga que ver con el guiado o PHD2 propiamente.
La gráfica es similar en las que salen bien y las otras. Tampoco puedo asegurarlo al 100%.
Tratar por analogía de revisar los mensajes que se dan cuando la imagen sale bien y cuando sale mal.
Justo antes del fragmento de mensajes que se ven el de arriba que apenas se ve pinta algo de WARNING...
Y el siguiente es que el dithering ha acabado con éxito. Revisar en los foros a ver que es ese warning
Siento no poder ser de gran ayuda. No veo nada más. 

« Últ. modif.: Dom, 30 Ago 2020, 18:14 UTC por roberbass80 »
- - -

teredur

**
Vitoria-Gasteiz 
desde: ago, 2017
mensajes: 236
clik ver los últimos




minimensaje
« respuesta #19 del : Lun, 31 Ago 2020, 07:50 UTC »

Gracias por los comentarios, intentare abrir un post en indilib, pero mi Ingles no da para mucho.

En los últimos apilados que he hecho de esos días me genera mucha margen negro (+100px) en los lados de la foto disminuiré la amplitud dithering y probaremos.

- - -

teredur

**
Vitoria-Gasteiz 
desde: ago, 2017
mensajes: 236
clik ver los últimos




minimensaje
« respuesta #20 del : Jue, 03 Sep 2020, 10:08 UTC »

Solo por comentar. Me he podido escapar esta noche a hacer unas tomas y probar los ajustes que tenia pendientes.
En cuanto al Dithering, he disminuido la cantidad de pixeles del desplazamiento a 0,8, como resultado: No hay estrellas dobles, aunque alguna estrella ligeramente ovalada veo, afinare ese valor.

Gracias por la ayuda.

- - -

Nolomar

**

avatarc

Manuel

Quijorna (Madrid) 
desde: ene, 2014
mensajes: 1177
clik ver los últimos




minimensaje
« respuesta #21 del : Vie, 04 Sep 2020, 13:52 UTC »

walking noise

- - -

ugatza

**

desde: feb, 2010
mensajes: 35
clik ver los últimos




minimensaje
« respuesta #22 del : Lun, 07 Sep 2020, 09:18 UTC »

Te he mandado un mensaje privado, Teredur.

- - -

teredur

**
Vitoria-Gasteiz 
desde: ago, 2017
mensajes: 236
clik ver los últimos




minimensaje
« respuesta #23 del : Lun, 07 Sep 2020, 13:45 UTC »

Te he mandado un mensaje privado, Teredur.
Te conteste el fin de semana, y te he vuelto a contestra ahora,  ¿ no te han llegado?

Enviado desde mi SM-A505FN mediante Tapatalk


- - -

keywords:   Ir Arriba  subir
Página: [1]    subir2  * final de la última página, y fin de tema.*
Imprimir
 
navegar a otro subforo:  
Tema: Dithering - Pregunta sobre que valores usáis ? y pausa?
 (Leído 1473 veces)
0
astrons: votos: 0
_

recomendados por nuestro foro RECOMENDADOS desde el foro astrónomo.org :

Telescopio en Astroshop
libros LucusHost, el mejor hosting

| Índice Rápido de foros en Astrónomo.org | lista conjunta de temas actualizados |
CÓDIGOS HTML y BANNER PARA ENLAZAR A NUESTRA PÁGINA PRINCIPAL, click en: little banner astronomo.org
* para compartir temas específicos o fotos del álbum encontrarás los botones más arriba *
Licencia de Creative Commons 4.0 astronomo.org astronomo.org by each autor is licensed under a Creative Commons Reconocimiento-NoComercial-CompartirIgual 3.0 Unported License.
Permissions beyond the scope of this license may be available at administrator of Astronomo.org .
Powered by MySQL
Powered by PHP
astronomo.org© 2006 - 2023 ema
Powered by SMF 1.1.21 | SMF © 2015, Simple Machines
XHTML 1.0 válido!
CSS válido!
  home3b   subir rápido a encabezado la administración del foro no es, ni se hace necesariamente, responsable de la opinión de sus participantes
Página creada en 0.148 segundos con 53 queries.
subir rápido a encabezado    home2  
rightback